ねこかんロケット

Apple・Mac・ビデオゲーム・パソコン・エミュレータ係の雑談掲示板です 

WINGBEAT COFFEE ROASTERS
mednafen / にゃんこ
mednafenのコンパイルされたのは出まわってないでしょうか?
初心者なのでコンパイルの仕方が分かりません。
BIOS等は一応あります、PCSXR等仕様している為に。
仕様環境は、OS X 10.7.3 Intel Core i3 3.2Ghz メモリ14GBです。
No.5368 - 2012/02/27(Mon) 03:48:37

Re: mednafen / Jazzin
コンパイル済みのバイナリはあまり見かけませんね
MacPort などにありますがかなり古いものです。

コンパイルの作業は最低でもターミナルの使い方が
分からないと難しいと思います。
No.5370 - 2012/02/28(Tue) 02:34:45
(No Subject) / ユニパックの逆襲
はじめまして。「ユニパックの逆襲」と申します。
質問させて頂きたく失礼ながら書き込みさせて頂きました。


Emulator Enhancerについてですが、復刻版セガサターンUSBゲームパッドを購入したので下記ページを参考させて頂きApplication Support” フォルダにドラック&ドロップしてみましたが、Preferenceに「フルスクリーンモード」「ジョイスティック」「フィルター」「レジストレーション」などの項目がなぜか追加されません。
http://www5f.biglobe.ne.jp/~nekocan/group_lab/folder_enhancer/ht_enhancer.html


現在公開されているバージョン『Emulator Enhancer v2.4.0』が手持ちの『Genesis Plus v1.3.0』に合わないのだと自己解釈し、新バージョンの『Genesis Plus v1.3.1』に置き換えた所、macOS10.4.11では開けない様で使えなくなってしまい、旧バージョンの『Genesis Plus v1.3.0』を探すも自分では見付ることができなかった為、『Genesis Plus v1.2.8』を見付けたのでとりあえずそれを使っていますが、買ったばかりのセガサターンUSBゲームパッドも使えず、『旧バージョンの『Genesis Plus v1.3.0』も見付からず、それに合うEmulator Enhancerも探せず困っております。

どなたかご親切な方何卒ご教授頂けましたら幸いです。
No.5365 - 2012/02/24(Fri) 02:14:19

Re: 名称未設定 / Jazzin
古いバージョンはmac-emu.netのアーカイブにあります
http://www.mac-emu.net/~bannister/filemirror/


Genesis Plus v1.3.0 はないようなので
検索して見つけました

http://www.mobianlegends.com/ftp/plus/www.zophar.net/Emulators/Apple%20Macintosh/Sega%20Genesis%20-%20Sega%20CD%20-%20Sega%2032X/Genesis%20Plus/
No.5366 - 2012/02/24(Fri) 18:03:32

ありがとうございます! / ユニパックの逆襲
Jazzin様。

お教え頂いたアドレスで『Genesis Plus v1.3.0』『Emulator Enhancer v2.3』を入手出来ました。おかげさまでセガサターンUSBゲームパッドの設定も無事にできました。

Jazzin様、本当にありがとうございました。心より感謝致します。
No.5367 - 2012/02/26(Sun) 01:22:54
supermodel 起動 / sasa [ Mail ]
お邪魔します。
Supermodel_02a_OSX でrom起動できません。

$ cd /supermodel
$ open supermodel

だけでは下記のごとく終了してしまいます。??
---------------------------------------------
dyld: unknown required load command 0x80000022
Trace/BPT trap
logout

[プロセスが完了しました]
---------------------------------------------

romセットの方法をご教授願えませんでしょうか??;;;

当方の環境は
mac OS X
2GHz Intel Core 2 Duo
メモリ2GB 667 MHz DDR2 SDRAM
です。
No.5361 - 2012/02/10(Fri) 18:25:17

Re: supermodel 起動 / Jazzin
Supermodel はアプリケーションではないので open コマンドではなく

$ cd /Supermodel_02a
$ ./Supermodel <romset> [options] で起動してください。

(例)
$ ./Supermodel /Users/Jazzin/Documents/scud.zip

使い方やオプション設定等はヘルプを見てください。
$ ./Supermodel -h

またMAMEのクローンの様な仕組みがないので、ROMセットは
全てのデータがそろったzipファイルが必要です。

まだ正常に動作しないソフトもありますので、互換性については
公式サイトの「Which Games Are Supported?」を見てください。
No.5362 - 2012/02/10(Fri) 21:32:31

Re: supermodel 起動 / sasa
アドバイスありがとうございます!
しかし・・・下記表示となり、起動しません。。。
ーーーーーーーーーーーーーーーーーーーーーーーーーーー
dyld: unknown required load command 0x80000022
Trace/BPT trap
ーーーーーーーーーーーーーーーーーーーーーーーーーーー

下記のように入力しましたが何か間違いがあるのでしょうか?
(Supermodel_02aフォルダへの移動は出来ました)
ーーーーーーーーーーーーーーーーーーーーーーーーーー
$ cd /Users/<名前>/Desktop/Supermodel_02a
$ ./Supermodel /Users/<名前>/Desktop/Supermodel_02a/spikeofe.zip
ーーーーーーーーーーーーーーーーーーーーーーーーーー
(フォルダをDesktopへ移しました)

それと、同フォルダ上で
$ ./Supermodel -h
と入力してもやはり
ーーーーーーーーーーーーーーーーーーーーーーーーーーー
dyld: unknown required load command 0x80000022
Trace/BPT trap
ーーーーーーーーーーーーーーーーーーーーーーーーーーー
となってしまいます ????

何が悪いのでしょうか?

過去記事にあるように「コンパイル」なる作業が必要なのですか?

ちなみに、使用しているromは、Win用supermodel(32bit)では起動確認できているromですので、romは問題無いかと思います。
romはSupermodelと同フォルダ内に入れています。

何か基本的な事が抜けているのでしょうか。、、
当方、ターミナルはほぼ使ったことが無く、初心者でごめんなさい。。
No.5363 - 2012/02/11(Sat) 09:18:57

Re: supermodel 起動 / Jazzin
dyld:〜 はシステムライブラリ関係のエラーでした

これですね
http://www.supermodel3.com/Forum/viewtopic.php?f=5&t=81
https://discussions.apple.com/thread/2151112?start=0&tstart=0

10.5 Leopard には対応してないので自分で10.5用にコンパイルするか
10.6 Snow Leopard にアップデートしてください、って事でしょうか。
No.5364 - 2012/02/11(Sat) 13:41:24
mednafen0.9.19wip / WWA
0.9.18wipでどうやっても動作出来なかったので、
0.9.19wipだとコンパイル出来ましたが、
どうやってもPSのゲームが動作しません。
biosとイメージはPCSXで使用していたものですが、
mednafenでcueもしくはbinを読み込ませても動作しません。
またMDに関してもsmdイメージが動作しませんでした。(binはok)
MCDのBiosがus名しか対応してもらずjpのbiosを変更してもスタート画面がうまく動きません。
NekoLauncher Mednafen Ver 0.9.19を使用してるのですが、
BiosをSelectから指定してもうまく認識しないようで結局Biosの名前を設定画面に書かれてものに変更しないといけないようです。
PSはcue+binイメージに対応してないのでしょうか?
No.5354 - 2012/02/06(Mon) 18:20:45

Re: mednafen0.9.19wip / Jazzin
WWAさんどうも、コンパイルできたようで良かったです

> smdイメージが動作しません
調べてみたところMednafenではサポートされてないようですね
smdを対応させるソースとかあるみたいですが、正式なものでは
ないのでとりあえず bin に変換して起動した方がよさそうです。

> MCDのBiosがus名しか対応してもらず
これはちょっと分かりませんね、Mednafenの問題なのか
それとも元のエミュレータの仕様なのか。

> BiosをSelectから指定してもうまく認識しない
何かおかしいですね… 修正しておきます。

> PSはcue+binイメージに対応してないのでしょうか?
うちでは外付けのドライブから起動できず、cueファイルからPSやPCEを起動しています。
No.5355 - 2012/02/07(Tue) 02:58:17

Re: mednafen0.9.19wip / WWA
mednafen-09x.cfgを色々調べてみた所PSのBios項目がUS,JP,EUに分かれておりランチャーで変更出来るのはUSのみでした。
jpはSCPH5500.BINになっていたので、該当するbiosに変更したら起動できました。
MCDはbiosがus一つしかありませんでした。
mac対応のsmdイメージ変換ツールを探してるのですが、
なかなか見つかりません。
No.5356 - 2012/02/07(Tue) 17:32:29

Re: mednafen0.9.19wip / Jazzin
> smdイメージ変換ツール
uCON64で変換できました(要コンパイル)
ランチャーの方はもう少しお待ち下さい。
No.5357 - 2012/02/08(Wed) 02:46:48

Re: mednafen0.9.19wip / WWA
smdのイメージツールの件ありがとうございます。
mednafen0.9.19wipのPSエミュについて質問ですが、
セーブやロードを行われるたびに画面の下部にメッセージが表示されるのですが、このメッセージを非表示にする設定を知りませんか?
cfgを調べてみたのですが、該当する項目がわかりませんでした。
またPCEのMednafenv0.8セーブデータが0.9.19wipで使用出来ないのですが、なんとか利用する方法はありますか?
No.5358 - 2012/02/08(Wed) 18:40:08

Re: mednafen0.9.19wip / Jazzin
NekoLauncher Mednafen 0.9.19 (Build17) をリリースしました
問題の部分は直っていると思います

> 下部にメッセージが表示される
システムのOSDメッセージを消すような設定は見あたりませんね
どうしても邪魔ならソース /src/psx/psx.cpp の710行目を
コメントアウトするしかないでしょうか。

> Mednafenv0.8セーブデータ
同じ場所でセーブしたファイルをバイナリエディッタで開いて
0.8と0.9との差分を調べて合成するとか…
まるっきり違ってたらお手上げですけど。
No.5359 - 2012/02/09(Thu) 18:58:50

Re: mednafen0.9.19wip / WWA
> NekoLauncher Mednafen 0.9.19 (Build17) をリリースしました
> 問題の部分は直っていると思います
>
> > 下部にメッセージが表示される
> システムのOSDメッセージを消すような設定は見あたりませんね
> どうしても邪魔ならソース /src/psx/psx.cpp の710行目を
> コメントアウトするしかないでしょうか。
>
> > Mednafenv0.8セーブデータ
> 同じ場所でセーブしたファイルをバイナリエディッタで開いて
> 0.8と0.9との差分を調べて合成するとか…
> まるっきり違ってたらお手上げですけど。

Build17を使ってみました。
PCE、PSのBiosの方はバッチリ選択できるようになりました。
ただし、MCDはどうもエミュ側がusにしか対応してないようで、jpbiosだとスタートの画面が異常でボタンも効かないのでゲームをするのは無理でした。
PSのメッセージの件ですが、またコンパイルし直さないといけないようならここまま使おうかと思います。
SAVE以外にメッセージが必要な場面で不便だと思うので。
セーブデータは大したセーブは無いのですが、
違っていたのでちょっとショックでした。
セーブデータの名前は別物で拡張子は同じ、名前だけ変えてしまったらさすがに異常動作しそうで怖いですね。
時間が空いた時にバイナリエディタで見ようかと。
ありがとうございました。
No.5360 - 2012/02/09(Thu) 20:35:18
mednafen-0.9.18-wip : Assertion failed! / Nikolay [ Mail ]
Hi guys! I have tried to install mednafen on my Mac (OS X 10.7.2 Lion)
The installation was successful, however, when trying to launch,
I receive the following error:
Starting Mednafen 0.9.18-WIP
Base directory: /Users/quickcracker/.mednafen
Internal emulation modules: nes snes gb gba pce pce_fast lynx md pcfx ngp vb wswan sms gg cdplay
External emulation modules:
Assertion failed: ((a + 0x7FFFFFFE) < a), function TestSignedOverflow, file tests.cpp, line 308.
Abort trap: 6


Has anybody encountered this issue and successfully solved it?
I have followed all your instructions, set up CFLAGS and CXXFLAGS,
also tried to edit configure.ac file before compilation, but nothing helps!
No.5352 - 2012/01/21(Sat) 21:44:26

Re: mednafen-0.9.18-wip : Assertion failed! / Jazzin
Please try a new Mednafen 0.9.19-WIP!

http://forum.fobby.net/index.php?t=msg&th=701&start=0&
No.5353 - 2012/01/30(Mon) 21:42:14
mednafen-0.9.18-wipのコンパイルエラー / WWA
NekoLauncher Mednafen 0.9.18がリリースされたのでmednafen-0.9.18-wipを入手しコンパイルしようとしたのですがうまくいきません。
AX_CFLAGS_GCC_OPTION([-fno-strict-overflow], OPTIMIZER_FLAGS) を
 AX_CFLAGS_GCC_OPTION([-fwrapv], OPTIMIZER_FLAGS) に変更して
./configure –build=x86_64-apple-darwin10.8.0だと
configure: error: invalid variable name: `–build'
と出て、
./configure –without-SDL_net –without-libcdio –without-libsndfile –disable-jack –disable-debugger –build=x86_64-apple-darwin10.0.0 –enable-psx
にすると
configure: WARNING: you should use --build, --host, --target
configure: WARNING: invalid host type: –without-SDL_net
configure: WARNING: you should use --build, --host, --target
configure: WARNING: invalid host type: –without-libcdio
configure: WARNING: you should use --build, --host, --target
configure: WARNING: invalid host type: –without-libsndfile
configure: WARNING: you should use --build, --host, --target
configure: WARNING: invalid host type: –disable-jack
configure: WARNING: you should use --build, --host, --target
configure: WARNING: invalid host type: –disable-debugger
configure: error: invalid variable name: `–build'
のエラー
./configureのみだと
checking for _mkdir... no
checking whether mkdir takes one argument... no
checking for pkg-config... /usr/local/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for library containing clock_gettime... no
checking for clock_gettime... no
checking OpenGL/gl.h usability... no
checking OpenGL/gl.h presence... no
checking for OpenGL/gl.h... no
checking for X... no
checking GL/gl.h usability... no
checking GL/gl.h presence... no
checking for GL/gl.h... no
configure: error: *** OpenGL header file not found!
でエラーが出て終了してしまいます。
libSDL_netとlibcdioとlibSDL_netとlibsndfileは入っていますし、mednafenの0.8Dはコンパイル前回できました。
10.6.8
No.5334 - 2011/11/10(Thu) 04:07:49

Re: mednafen-0.9.18-wipのコンパイルエラー / Jazzin
すいません、WordPressの不具合でハイフンx2(--)が勝手に「–」へ変換されてしまったようです。正しくはハイフンx2(--)です、ブログの記事は修正しておきました。

./configure --build=x86_64-apple-darwin10.0.0 --disable-debugger でどうでしょう

詳しいコンフィグのオプションは ./configure -help で表示されます
No.5335 - 2011/11/10(Thu) 20:41:00

Re: mednafen-0.9.18-wipのコンパイルエラー / WWA
> すいません、WordPressの不具合でハイフンx2(--)が勝手に「–(–)」へ変換されてしまったようです。正しくはハイフンx2(--)です、ブログの記事は修正しておきました。
>
> ./configure --build=x86_64-apple-darwin10.0.0 --disable-debugger でどうでしょう
>
> 詳しいコンフィグのオプションは ./configure -help で表示されます


お騒がせしますJazzin様
試してみましたが、
./configureのみの場合と同じconfigure: error: *** OpenGL header file not found!というエラーがでてしまします。
No.5336 - 2011/11/10(Thu) 20:43:45

Re: mednafen-0.9.18-wipのコンパイルエラー / Jazzin
configure.ac の63行目にあるOpenGLのチェックに引っかかってますね…
うちのコンフィグはこんな感じです
http://nekocan.sitemix.jp/wp-content/uploads/2011/11/log.txt

OpenGL.framework に gl.h は入ってますでしょうか?

/System/Library/Frameworks/OpenGL.framework/Versions/A/Headers/gl.h
No.5337 - 2011/11/11(Fri) 00:24:27

Re: mednafen-0.9.18-wipのコンパイルエラー / WWA
なぜかHeadersが無かったのでTimeMachineで復元したものの変わらなかったので、Xcodeを再インストールし更新した所、時間はかかったもののコンパイル出来ましたが、NekoLauncher Mednafen v0.9.18にインストールし環境設定を見ると設定項目が真っ白。仕方なくマニュアルと0.8Dの設定を見ながらなんとか設定をしたものの、なぜかPCEのCDとカードどちらも起動出来ないor強制終了が発生してPlayできませんでした。
Mednafenがちゃんとコンパイル出来ているのか確認が出来ればいいのですが、コマンドライン入力がよくわからないのと0.8Dの設定が書き換えられそうなので現在の所していません。
ランチャーの環境設定ウインドウをしばらく開いているだけで強制終了してしまいます。
Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000010
Crashed Thread: 0 Dispatch queue: com.apple.main-thread
No.5338 - 2011/11/11(Fri) 02:20:13

Re: mednafen-0.9.18-wipのコンパイルエラー / WWA
試しにターミナルから/.mednafenをやってみた所
Starting Mednafen 0.9.18-WIP
Base directory: /Users/WWA/.mednafen
Internal emulation modules: nes snes gb gba pce pce_fast lynx md pcfx ngp psx vb wswan sms gg cdplay
External emulation modules:
128 1905 1920 -1920
Math test failed: tests.cpp:154
Math test failed: tests.cpp:154
logout
となったのですが、正常なのでしょうか?
No.5339 - 2011/11/11(Fri) 03:10:56

Re: mednafen-0.9.18-wipのコンパイルエラー / Jazzin
> となったのですが、正常なのでしょうか?
コンパイルはされたもののエミュレータの起動に失敗しているようですね
http://forum.fobby.net/index.php?t=msg&&th=659&goto=2214#msg_2253

configure.ac の書き換えなし、や --buildオプションなし、ではどうでしょう

> 境設定を見ると設定項目が真っ白
ランチャーを起動するとMednafenのコンフィグ設定「~/.mednafen/mednafen-09x.cfg」を読み込んで、ランチャーのPreferenceに設定されます。mednafen-09x.cfg ファイルがないと設定が読み込めないためGUIが真っ白になります。
Mednafenが正常に起動できない性で.cfgファイルの作成に失敗しているのかもしれません。ランチャーが強制終了する問題は修正します。

ターミナルからの起動は
./mednafen <path/rom名> で起動できます。
No.5340 - 2011/11/11(Fri) 21:08:36

Re: mednafen-0.9.18-wipのコンパイルエラー / WWA
> > となったのですが、正常なのでしょうか?
> コンパイルはされたもののエミュレータの起動に失敗しているようですね
> http://forum.fobby.net/index.php?t=msg&&th=659&goto=2214#msg_2253
>
> configure.ac の書き換えなし、や --buildオプションなし、ではどうでしょう

--buildオプションなしだとmakeファイルが作成されませんでした。
configure.acの書き換え無しでコンパイルしたファイルを実行すると全く同じMath test failed: tests.cpp:154が発生。
他のオプションを削ったりしてみましたが、同じ結果になりました。
0.8D3と違って他にもなにかライブラリが必要なのでしょうか?
No.5341 - 2011/11/12(Sat) 05:10:38

Re: mednafen-0.9.18-wipのコンパイルエラー / WWA
書き忘れました
GCCver4.2.1 Xcode3.26 SDL1.2.14 SDL_net1.2.7 pkg-config-0.25 libsndfile-1.0.25 libcdio-0.82 JackAudioなし
No.5342 - 2011/11/12(Sat) 05:33:18

Re: mednafen-0.9.18-wipのコンパイルエラー / Jazzin
ライブラリは多分問題ないと思います
うちの環境でもコンフィグの修正なしでは Math test failed: tests.cpp:154 のエラーや Assertion failed: ((a + 0x7FFFFFFE) < a), function 〜のエラーが発生してました。

OSXのバージョンとCPU名は分かりますでしょうか。
No.5343 - 2011/11/13(Sun) 03:08:13

Re: mednafen-0.9.18-wipのコンパイルエラー / WWA
OSX10.6.8
2.66GHzQuad-Core
です。
configure.acの一部分
AX_CFLAGS_GCC_OPTION([-fomit-frame-pointer], OPTIMIZER_FLAGS)
AX_CFLAGS_GCC_OPTION([-finline-limit=6000], OPTIMIZER_FLAGS)
AX_CFLAGS_GCC_OPTION([--param large-function-growth=800], OPTIMIZER_FLAGS)
AX_CFLAGS_GCC_OPTION([--param inline-unit-growth=175], OPTIMIZER_FLAGS)
AX_CFLAGS_GCC_OPTION([--param max-inline-insns-single=10000], OPTIMIZER_FLAGS)
AX_CFLAGS_GCC_OPTION([-fwrapv], OPTIMIZER_FLAGS)
でよろしいでしょうか?
なぜかmakeファイルを開き-fwrapvを検索すると見つからず、
-fno-strict-overflowを検索すると見つかります。
ということはconfigure.acの変更が読み込まれていないのでしょうか?
No.5344 - 2011/11/13(Sun) 04:04:00

Re: mednafen-0.9.18-wipのコンパイルエラー / Jazzin
> AX_CFLAGS_GCC_OPTION([-fwrapv], OPTIMIZER_FLAGS)
> でよろしいでしょうか?


そうですね、編集するのはconfigure.acの102行目だけです。
makeファイルは何も編集しませんでした。

ランチャーを更新しました(build 2)、強制終了せずにエラーのアラートが出ると思います。実行ファイルも公開します、うちの環境でビルドしたものなので必要なライブラリがないと起動できないかもしれません。

http://nekocan.sitemix.jp/wp-content/uploads/2011/11/Mednafen0918.zip
No.5345 - 2011/11/13(Sun) 13:12:43

Re: mednafen-0.9.18-wipのコンパイルエラー / WWA
> > AX_CFLAGS_GCC_OPTION([-fwrapv], OPTIMIZER_FLAGS)
> > でよろしいでしょうか?
>
> そうですね、編集するのはconfigure.acの102行目だけです。
> makeファイルは何も編集しませんでした。
>
> ランチャーを更新しました(build 2)、強制終了せずにエラーのアラートが出ると思います。実行ファイルも公開します、うちの環境でビルドしたものなので必要なライブラリがないと起動できないかもしれません。
>
> http://nekocan.sitemix.jp/wp-content/uploads/2011/11/Mednafen0918.zip


さっそく試してみました。
実行ファイルは強制終了を起して実行出来ませんでした。
やはり何かライブラリが不足しているようです(あるいはVerが違う)。
開発環境.txtに書かれているファイルが存在するかチェックしました。
libz.1.2.3.dylib
libstdc++.6.0.9.dylib
libSDL_net-1.2.0.0.7.dylib
のみtxtに記載された名前のエイリアスがありオリジナルは上記のファイル名で他は同名の実行ファイルが存在しました。
No.5346 - 2011/11/13(Sun) 15:44:41

Re: mednafen-0.9.18-wipのコンパイルエラー / Jazzin
> 実行ファイルは強制終了を起して実行出来ませんでした。
やはり環境が違うと起動しませんか

以下はエイリアスではなくシンボリックリンクです
libstdc++.6.dylib -> libstdc++.6.0.9.dylib
libSDL_net-1.2.0.dylib -> libSDL_net-1.2.0.0.7.dylib
libz.1.dylib -> libz.1.2.5.dylib

OSX10.7では libz が1.2.5になってますね
http://zlib.net/
No.5347 - 2011/11/14(Mon) 01:58:05

Re: mednafen-0.9.18-wipのコンパイルエラー / WWA
libzを1.2.5にして試してみましたが、変わらず、
configを見てみると
checking SDL_net.h usability... yes
checking SDL_net.h presence... yes
checking for SDL_net.h... yes
の部分がすっぱり抜けているのを発見し、
SDL_netを再度installしましたが、結果は変わりませんでした。
作成されたmednafenファイルは毎回10.9MBです。
mednafenコンパイル終了後はsudo make installはしていません。
No.5348 - 2011/11/14(Mon) 17:53:22

Re: mednafen-0.9.18-wipのコンパイルエラー / WWA
その後
SDL_net1.2.7とSDL-1.2.14を再インストール
libcddb-1.3.2を再インストール後libcdio-0.83をインストール
したもののmednafenの実行ファイルに変化は見られませんでした。
./configure --without-SDL_net --without-libcdio --without-libsndfile --disable-jack --disable-debugger --build=x86_64-apple-darwin10.0.0 --enable-psx
で約10.9MB、
./configure --disable-debugger --build=x86_64-apple-darwin10.0.0 --enable-psx
で11.9MBほどのファイルが作成されます。
オプションに変化を加えてもやはり同様のエラーが発生しました。
まさか0.9.18wipはXcode4のみ対応という訳ではありませんよね?
No.5349 - 2011/11/17(Thu) 22:21:48

Re: mednafen-0.9.18-wipのコンパイルエラー / Jazzin
コンパイルはされているのでxcodeのコンパイラーには問題ないと思います
mednafen の --buildオプションやconfigure.acでうまく環境が合わずに
/src/tests.cpp に引っかかってエラーが起こっているものと思われます。
No.5350 - 2011/11/18(Fri) 02:52:17

Re: mednafen-0.9.18-wipのコンパイルエラー / WWA
configure.acを削除して./configureを実行しても何事も無くmakefileが作成され、-fwrapvに書き換えてもmakefileに-fwrapvが全く無く-fno-strict-overflowがあるのを考えるとconfigure.acが読み込まれてない気がします。
うーん・・・
No.5351 - 2011/11/22(Tue) 03:30:38
(No Subject) / nobu
どう頑張っても出来ないので

パッケージ化されるまで待ちます。

ありがとうございました。
No.5322 - 2011/10/02(Sun) 20:58:20

Re: 名称未設定 / Jazzin
コンパイル済みのバイナリ(64-bit Intel)がアップされていました。
パッケージ化はされてないので、ターミナルからの起動になりますが…

http://www.Supermodel3.com
No.5333 - 2011/10/25(Tue) 01:33:56
Mednafenのフレームスキップ / WWA
お久しぶりです
NekoLauncher Mednafen v0.8.D.1+Mednafen v0.8.D3
を使用してます。
時々コマ落ちしたようになるのでフレームスキップを解除したいのですが、Mednafenの環境設定ファイルおよびNekoLauncherの設定にフレームスキップの項目がありません。
Motion blur each frame with the last frameの有効にするとフレームスキップが無効になり、コマ落ちしないようですが、表示が見にくくなるので使えませんでした。
フレームスキップのみ無効にする設定方法はありますか?
No.5330 - 2011/10/17(Mon) 14:59:59

Re: Mednafenのフレームスキップ / Jazzin
Mednafen 0.9.18-WIP には video.frameskip というオプショが用意されていますが、v0.8.D.3 には無いようですね。
No.5331 - 2011/10/17(Mon) 23:07:21

Re: Mednafenのフレームスキップ / WWA
> Mednafen 0.9.18-WIP には video.frameskip というオプショが用意されていますが、v0.8.D.3 には無いようですね。
そうですか…
HuカードはTGEmuを使えばいいようですが、
CDイメージが使えないのでMednafenしかないんですよね。
Mednafen 0.9.18-WIP対応ランチャーが出たら0.9.18-WIPを試してみようかなと思います。
No.5332 - 2011/10/18(Tue) 12:58:09
yabause-0.9.10-mac / tyobo
はじめまして。

yabause-0.9.10-macを開こうとしてもすぐに「予期しない理由で終了」してしまうのでどうすればよいか?を教えていただきたいとコメントしました。

1・まず、yabauseをダウンロードフォルダにダウンロード後、各種設定を済ませbiosも指定。

2・yabauseを開き起動確認。(SEGA STAURNのロゴ表示からディスクを入れる前の画面まで確認)romがないのでここまで。

3・書類フォルダ内にサターンフォルダを作成し、その中にyabauseを移動。

4・もう一度yabauseを開こうとすると「予期しない理由で終了」となる。

それ以後、ダウンロードフォルダに戻しても、削除してダウンロードしなおしても、違うバージョンのyabause-0.9.9-mac
をダウンロードしてもダメです。

環境 imac Intel Core 2 Duo 2.66 GHz メモリ4 GB
   OS X 10.6.8

対処法を知っておられたら教えてください。
No.5323 - 2011/10/11(Tue) 23:19:53

Re: yabause-0.9.10-mac / Jazzin
何でしょうね
うちの環境でも同じように書類フォルダにアプリケーションを移動して起動してみましたが、とくに問題はありませんでした。
http://cgi.www5f.biglobe.ne.jp/%7enekocan/cgi/gazoubbs20070515/bbs29.cgi

取り敢えず初期設定ファイル「org.yabause.Yabause.plist」を削除してみてはどうでしょう。
No.5324 - 2011/10/13(Thu) 01:55:57

Re: yabause-0.9.10-mac / tyobo
ご回答ありがとうございます。

>>取り敢えず初期設定ファイル「org.yabause.Yabause.plist」を削除してみてはどうでしょう。

パッケージの内容を表示させてみましたが、上記のファイルがありません。

とりあえずContent内のinfo.plistファイルを削除してみると開いたのですがbios指定してromを開こうとすると再び「予期しない〜」で終了。
その後、同じように再ダウンロード後、info.plistファイルを削除しても最初から「予期しない〜」でいっこうに開きません。
No.5325 - 2011/10/13(Thu) 20:46:40

Re: yabause-0.9.10-mac / tyobo
上記の無知な質問をして失礼いたしました。

先ほどご指摘のあったファイルを削除したところ、当初起動した時と同じように動きました。

しかし、ダウンロードフォルダ内であれば動くのですが書類フォルダ内に移すと「予期しない〜」になり、初期設定ファイルを削除してもダメですが、ダウンロードフォルダに戻して初期設定ファイルを消すと起動します。

この件に関しては対処法はあるでしょうか?
No.5326 - 2011/10/13(Thu) 21:14:39

Re: yabause-0.9.10-mac / Jazzin
書類フォルダ以外の場所ではどうでしょう

初期設定ファイルを削除してからアプリケーションを移動、
起動してBios指定、エミュレーションをスタート

あとはディスクユーティリティでアクセス権の修復とかですかね
No.5327 - 2011/10/14(Fri) 02:24:56

Re: yabause-0.9.10-mac / tyobo
ご回答ありがとうございます。

アドバイス通りにしてみたのですがダメでした。アクセス権の修復も試みたのですが・・・無理でした。

しかし、新たな問題が見つかりまして、中古でEVE burst errorを購入してきて起動させようと思ったのですがディスクを読み込みません。

yabauseのmac osx guideの指示通りcdrom設定で[cdrom devise]を選択肢、その上部に「/dev/disk1」と入れたのですが何も読み込まない時の画面です。

/dev/disk2にしたり、ディスク内のBINファイルを指定してみたりcueファイルに変換してみたり(これにすると強制終了になってしまいます)とアタックしてみましたがいっこうに読み込みません。

設定の仕方が間違ってるでしょうか?
No.5328 - 2011/10/14(Fri) 21:09:56

Re: yabause-0.9.10-mac / Jazzin
もちろん動作しないソフトもあります、まだ完璧なエミュレータではありませんので正常に動かないソフトの方が多いかもしれません。

cdromの設定は空白のままで自動でロードしてくれると思います。他のディスクをロードしてしまう場合に指定するといった感じでしょうか。

ディスクのパスは「diskutil」コマンドで調べられます。
http://cgi.www5f.biglobe.ne.jp/%7enekocan/cgi/gazoubbs20070515/bbs29.cgi
No.5329 - 2011/10/16(Sun) 02:33:15
Supermodel v0.2aコンパイル / nobu
Supermodel v0.2aのコンパイル方法が分かりません。
コンパイルもまったくの素人なので詳しく教えて
もらえると嬉しいです。
仕様環境はimac 21.5 corei7 2600S OSはLionです。
No.5316 - 2011/09/27(Tue) 23:28:58

Re: Supermodel v0.2aコンパイル / Jazzin
まずはXcodeをインストールしてください。
No.5318 - 2011/09/28(Wed) 02:49:44

Re: Supermodel v0.2aコンパイル / nobu
Xcodeはインストールしてあります。
SDL framework も入れてあります。
どこからターミナルを動かすのか
あとその後の操作も分からないんです。
まったく素人で申し訳ございません。
No.5319 - 2011/09/28(Wed) 07:03:53

Re: Supermodel v0.2aコンパイル / Jazzin
ターミナルの使い方については「ターミナル コマンド」「UNIX コマンド」などで検索してください。

1. ダウンロードした Supermodel v0.2a を解凍してホームフォルダに置きます。
2. /アプリケーション/ユーティリティ/の中にある ターミナル.app を起動します。
3. 以下のコマンドを入力。
cd /Users/ユーザー名/Supermodel_0.2a_Src

make -f /Users/ユーザー名/Supermodel_0.2a_Src/Makefiles/Makefile.SDL.OSX.GCC

4. コンパイルに成功すると binフォルダに実行ファイル「Supermodel」が出来上がります。
No.5321 - 2011/09/28(Wed) 23:03:48
以下のフォームに記事No.と投稿時のパスワードを入力すれば
投稿後に記事の編集や削除が行えます。
200/200件 [ ページ : << 1 ... 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 ... 20 >> ]

- HOME - お知らせ(3/8) - 記事検索 - 携帯用URL - フィード - ヘルプ - 環境設定 -

Rocket Board Type-LS (Free) Rocket BBS